Cómo Instalar Node.js y npm en Ubuntu y derivados

nodejs

Para las versiones de Ubuntu y derivados (Mint, Elementary, etc) entre 12.04 y 13.04, existe en los repositorios una versión vieja (0.60x) de Node. Para las versiones más nuevas 13.10 y 14.04, las versiones presentes son 0.10.X. Para instalarlo:

  sudo apt-get install nodejs

Para instalar npm en Ubuntu 13.10 y 14.04 y sus derivados (Mint, Elementary, etc):

  sudo apt-get install npm

Para obtener una versión reciente de Node sobre una de las versiones viejas de Ubuntu se requieren algunos pasos extra. Por ejemplo:

  sudo add-apt-repository ppa:chris-lea/node.js
  sudo apt-get update
  sudo apt-get install python-software-properties python g++ make nodejs

Esto instala la última versión de Node sobre la última versión de Ubuntu.

El comando add-apt-repository lo provee el paquete python-software-properties. Así que necesitaremos instalarlo también

  sudo apt-get install python-software-properties

Desde Node.js v0.10.0, el paquete nodejs del repositorio de Chris Lea incluye tanto a npm como nodejs-dev.

Existe un conflicto de nombre con el paquete node, y el binario de nodejs ha sido renombrado de node a nodejs. Necesitaremos un enlace simbólico de /usr/bin/node hacia /usr/bin/nodejs o podemos desinstalar Amateur Packet Radio Node Program para evitar el conflicto de nombres.

Opcional: Para evitar la utilización de sudo para los comandos de npm:

  npm config set prefix ~/npm

Añadimos $HOME/npm/bin al $PATH, y agregamos al final de nuestro .bashrc la siguiente línea:

  export PATH=$HOME/npm/bin:$PATH
Anuncios

6 comentarios en “Cómo Instalar Node.js y npm en Ubuntu y derivados

  1. Yo tengo un problema me sale esto al instentar instalar el npm
    Los siguientes paquetes tienen dependencias incumplidas:
    npm : Depende: nodejs pero no va a instalarse
    Depende: node-abbrev (>= 1.0.4) pero no va a instalarse
    Depende: node-ansi pero no va a instalarse
    Depende: node-archy pero no va a instalarse
    Depende: node-block-stream pero no va a instalarse
    Depende: node-fstream (>= 0.1.22) pero no va a instalarse
    Depende: node-fstream-ignore pero no va a instalarse
    Depende: node-github-url-from-git pero no va a instalarse
    Depende: node-glob (>= 3.1.21) pero no va a instalarse
    Depende: node-graceful-fs (>= 2.0.0) pero no va a instalarse
    Depende: node-inherits pero no va a instalarse
    Depende: node-ini (>= 1.1.0) pero no va a instalarse
    Depende: node-lockfile pero no va a instalarse
    Depende: node-lru-cache (>= 2.3.0) pero no va a instalarse
    Depende: node-minimatch (>= 0.2.11) pero no va a instalarse
    Depende: node-mkdirp (>= 0.3.3) pero no va a instalarse
    Depende: node-gyp (>= 0.10.9) pero no va a instalarse
    Depende: node-nopt (>= 2.1.1) pero no va a instalarse
    Depende: node-npmlog pero no va a instalarse
    Depende: node-once pero no va a instalarse
    Depende: node-osenv pero no va a instalarse
    Depende: node-read pero no va a instalarse
    Depende: node-read-package-json (>= 1.1.0) pero no va a instalarse
    Depende: node-request (>= 2.25.0) pero no va a instalarse
    Depende: node-retry pero no va a instalarse
    Depende: node-rimraf (>= 2.2.2) pero no va a instalarse
    Depende: node-semver (>= 2.1.0) pero no va a instalarse
    Depende: node-sha pero no va a instalarse
    Depende: node-slide pero no va a instalarse
    Depende: node-tar (>= 0.1.18) pero no va a instalarse
    Depende: node-which pero no va a instalarse
    E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

    QUe puedo hacer??

    • Parece un problema con las dependencias. En primer lugar desinstalaría todos los paquetes de node y nodejs. Luego sigue la guía que escribí en este mismo post y no deberías tener ningún inconveniente.

      Éxitos en la tarea! 🙂

    • Hola Camilo, en efecto este post no está actualizado, lo publiqué el 20 de mayo, 2014. Bastante viejo como para funcionar ahora.

      Tal vez haga un nuevo post sobre el tema acorde a las versiones actuales.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s